const regex = /^(?:\d+(?:\?(?:\([\da-z]+\))?|[A-Z]+) ?)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d+(?:\\?(?:\\([\\da-z]+\\))?|[A-Z]+) ?)+$', 'gm')
const str = `3A 1?(1) 2?(2) 3?(a) 4?(4) 5?(a) 6?(ii) 7?
4 6?(1) 7?(2) 8?(a) 9?(4) 10?(a) 11?(ii) 12? `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}