re = /(?<=строка1).*(?<=строка1)(?'res'.*?)(?=строка2)/m
str = 'строка1 плваопо валпваоп строка1 ьопау лдпаа строка2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end