$re = '/(\d+)\s(?:-\s)?(.*)/m';
$str = '12345 - Red Apples S
34567 Blue Oranges';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);