#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z\s\d\/\+\(\)\#\&]*$"
Local $sString = "Card Name #1" & @CRLF & _
"Card Name (1)" & @CRLF & _
"Card Name / 1" & @CRLF & _
"Card Name &1" & @CRLF & _
"Card_Name + 1" & @CRLF & _
"card -sd" & @CRLF & _
"Card_Name"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")