$re = '/^(.+)\n\1/m';
$str = '...
one
two
two
three
...
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);