const regex = /^-?(0(b([01]+(\.[01]*)?|\.[01]+)|x([0-9a-f]+(\.[0-9a-f]*)?|\.[0-9a-f]+)|o([0-7]+(\.[0-7]*)?|\.[0-7]+))(p[+-]?\d+)?|(\d+(\.\d*)?|\.\d+)(e[+-]?\d+)?)$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?(0(b([01]+(\\.[01]*)?|\\.[01]+)|x([0-9a-f]+(\\.[0-9a-f]*)?|\\.[0-9a-f]+)|o([0-7]+(\\.[0-7]*)?|\\.[0-7]+))(p[+-]?\\d+)?|(\\d+(\\.\\d*)?|\\.\\d+)(e[+-]?\\d+)?)$', 'i')
const str = `^0b([01]+(\\.[01]*)?|\\.[01]+)(p[+-]?\\d+)?\$
^0x([0-9a-f]+(\\.[0-9a-f]*)?|\\.[0-9a-f]+)(p[+-]?\\d+)?\$
^0o([0-7]+(\\.[0-7]*)?|\\.[0-7]+)(p[+-]?\\d+)?\$
^(\\d+(\\.\\d*)?|\\.\\d+)(e[+-]?\\d+)?\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}