const regex = /^(?:[^_]*_){7}([^_]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^_]*_){7}([^_]*)', 'gm')
const str = `abc_fjs_dja_sja_dj_sadjasdksa_sdjakd_match_fsja_fsdk`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}