// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[^_]*_){7}([^_]*)").unwrap();
let string = "abc_fjs_dja_sja_dj_sadjasdksa_sdjakd_match_fsja_fsdk";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}