use strict;
my $str = '{if $name == \'Tree\'}
Hey, this is a Tree!
{/if}
{if $name == \'Example\'}
{if $number == \'1\'}
Hey, this is an Example with the number 1
{/if}
{/if}';
my $regex = qr/\{if\s{1}(.+?)\}\n(((?R)|.*?)+)\{\/if\}/misp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}