re = /\{if\s{1}(.+?)\}\n(((?R)|.*?)+)\{\/if\}/mi
str = '{if $name == \'Tree\'}
Hey, this is a Tree!
{/if}
{if $name == \'Example\'}
{if $number == \'1\'}
Hey, this is an Example with the number 1
{/if}
{/if}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end