$re = '/\{if\s(.+?)}\R((?>(?!\{\/?if[}\s]).|(?R))*?)\{\/if}/mis';
$str = '{if $name == \'Tree\'}
Hey, this is a Tree!
{/if}
{if $name == \'Example\'}
{if $number == \'1\'}
Hey, this is an Example with the number 1
{/if}
{/if}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);