const regex = /г.([А-Яа-я\s\-]+)[, ]?(([ ]?)+(ул|пр|пер|пр-т|б-р|бул)\s?\.?)([\-А-Яа-я \.]+)[, ](.+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('г.([А-Яа-я\\s\\-]+)[, ]?(([ ]?)+(ул|пр|пер|пр-т|б-р|бул)\\s?\\.?)([\\-А-Яа-я \\.]+)[, ](.+)', '')
const str = ` г.Минск ,пр-т. Победителей, 63/1-2, пом.131`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}