using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(-?(?:(?=[1-9]|0(?!\d))\d+(?:\.\d+)?)|\.\d+)$";
string input = @"0
1
0.2
1.23
-12
.234
00
0123
1223332.4434
02.4232
-3.343";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}