re = /(((mailto\:|(news|(ht|f)tp(s?))\:\/\/){1}\S+)\s){1,}((mailto\:|(news|(ht|f)tp(s?))\:\/\/){1}\S+)$/m
str = 'http://www.google.com http://www.stackoverflow.com
http://www.google.com and http://www.stackoverflow.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end