#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:[^0-9]*[0-9]){4})[0-9A-Z.-]+$"
Local $sString = "ART-4.5-11" & @CRLF & _
"ART5411" & @CRLF & _
"76543" & @CRLF & _
"" & @CRLF & _
"aRT-4!5-1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")