#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!0*\.0+$)\d*(?:\.\d+)?$"
Local $sString = "0.07" & @CRLF & _
"0.0" & @CRLF & _
"20" & @CRLF & _
"0.00007" & @CRLF & _
"0.0000" & @CRLF & _
".007" & @CRLF & _
"5.00" & @CRLF & _
"4.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")