package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[2-9TJQKA]+\b`)
var str = `643TJAKQ
72MAJTQ
1246AKJQ
AKT432`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}