# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(>)()(<\/)"
test_str = (" <file> \n"
" <fileType>Mezza</fileType>\n"
" <fileName></fileName>\n"
" <any_other_tag></any_other_tag>\n"
" <any_other_tag> </any_other_tag>\n"
" <segments>0000</segments>\n"
" </file>")
subst = "\\1[!] value does not exist!\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.