re = /^[a-zA-Z]+(?:[ `-][a-zA-Z]+)* ?$/m
str = 'Valid:
text-text
text text
text`text
text-text`text
text text-text
text`text text
--> INVALID
text``text text
text`text text
text`text -text
--> VALID
text
--> INVALID
text
`text
text`
-text
text-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end