$re = '/([a-zA-Z]{4})([a-zA-Z]{2})(([2-9a-zA-Z]{1})([0-9a-np-zA-NP-Z]{1}))((([0-9a-wy-zA-WY-Z]{1})([0-9a-zA-Z]{2}))|([xX]{3})|)/m';
$str = 'DEKTDE7GXXX
GEBABEBB
BKAUATWW
COBADEFF060
UCJAES2MXXX
ESSEDE5F100
CMCIFRPP
CHASFIHHXXX
PBNKDEFF100
ZUNOCZPP
ABNACHZ8XXX
DNBANOKK
DEUTDEDB101
ARSPBE22
DXIADEBBXXX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);