#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)hipovitaminosis[\s]{0,3}D|d[eé]ficit[\s]{0,3}vitam[ií]na[\s]{0,3}D|deficiencia[\s]{0,3}[\S[\s]{0,3}vitam[ií]na[\s]{0,3}D|d[ée]ficit[\s]{0,3}vit[\s]{0,3}D|deficiencia[\s]{0,3}vit[\s]{0,3}D|vit[\s]{0,3}D[\s]{0,3}<30"
Local $sString = "hipovitaminosis D" & @CRLF & _
"Déficit vitamina D" & @CRLF & _
"Vit D <30" & @CRLF & _
"deficiencia de vitamina D" & @CRLF & _
"deficit vit D" & @CRLF & _
"deficiencia vit D" & @CRLF & _
"deficiencia vitamina D" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")