// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)hipovitaminosis[\s]{0,3}D|d[eé]ficit[\s]{0,3}vitam[ií]na[\s]{0,3}D|deficiencia[\s]{0,3}[\S[\s]{0,3}vitam[ií]na[\s]{0,3}D|d[ée]ficit[\s]{0,3}vit[\s]{0,3}D|deficiencia[\s]{0,3}vit[\s]{0,3}D|vit[\s]{0,3}D[\s]{0,3}<30").unwrap();
let string = "hipovitaminosis D
Déficit vitamina D
Vit D <30
deficiencia de vitamina D
deficit vit D
deficiencia vit D
deficiencia vitamina D
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}