// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^\w+\s\w+\s\w+\s)(\d{3})(.*)").unwrap();
let string = "Bach 2000 v03CD15 045 - Cantatas BWV 147-149
Bach 2000 v03CD05 1 - Cantata, BWV 112
Bach 2000 v03CD05 10 - Cantata, BWV 113
Bach 2000 v03CD1 1 - Cantata, BWV 100
Bach 2000 v03CD1 10 - Cantata, BWV 101
Bach 2000 v03CD1 020 - Cantata, BWV 102
Bach 2000 v03CD10 10 - Cantata, BWV 129";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}