import Foundation
let pattern = #"(^\w+\s\w+\s\w+\s)(\d{3})(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Bach 2000 v03CD15 045 - Cantatas BWV 147-149
Bach 2000 v03CD05 1 - Cantata, BWV 112
Bach 2000 v03CD05 10 - Cantata, BWV 113
Bach 2000 v03CD1 1 - Cantata, BWV 100
Bach 2000 v03CD1 10 - Cantata, BWV 101
Bach 2000 v03CD1 020 - Cantata, BWV 102
Bach 2000 v03CD10 10 - Cantata, BWV 129
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)