#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\/(.*?)_2022[_|\d]*(.*)_2022[_|\d]*\.\D{3}"
Local $sString = "/tenants/ct/108251/prod/rec/processing/olympic/olybl_ion_2022050045525_20220505_20221545848445.txt" & @CRLF & _
"/tenants/ct/108251/prod/rec/processing/olympic/APR_TLM_FXCASH_2022_05_15_SYS_Fwd_20221545663348.csv" & @CRLF & _
"/tenants/ct/108251/prod/rec/processing/apac/GLASS_APAC_CDGL_DAILY_20220415_2026556411478_EXEMPTION_20224547788955.txt" & @CRLF & _
"/tenants/ct/108251/prod/rec/processing/apac/GLASS_APAC_CDGL4_2022_03_03_20221545445568.csv" & @CRLF & _
"/tenants/ct/108251/prod/rec/processing/idda/t240287bl_1298672_20220803_202284775654.txt" & @CRLF & _
"/tenants/ct/108251/prod/rec/processing/idda/OPICS10390_BAL_KOR_20220407101255_20224545565677.txt" & @CRLF & _
"/tenants/ct/108251/prod/rec/processing/sap_fv/s4_idn_sap_abcd_tcs_future_20221015_20224545888886.csv" & @CRLF & _
"/tenants/ct/108251/prod/rec/processing/sap_fxrates/frontier_sgp_xrates_d_sap_20221105_20221234567812.dat"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")