const regex = /.*\/(.*?)_2022[_|\d]*(.*)_2022[_|\d]*\.\D{3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\\/(.*?)_2022[_|\\d]*(.*)_2022[_|\\d]*\\.\\D{3}', 'gm')
const str = `/tenants/ct/108251/prod/rec/processing/olympic/olybl_ion_2022050045525_20220505_20221545848445.txt
/tenants/ct/108251/prod/rec/processing/olympic/APR_TLM_FXCASH_2022_05_15_SYS_Fwd_20221545663348.csv
/tenants/ct/108251/prod/rec/processing/apac/GLASS_APAC_CDGL_DAILY_20220415_2026556411478_EXEMPTION_20224547788955.txt
/tenants/ct/108251/prod/rec/processing/apac/GLASS_APAC_CDGL4_2022_03_03_20221545445568.csv
/tenants/ct/108251/prod/rec/processing/idda/t240287bl_1298672_20220803_202284775654.txt
/tenants/ct/108251/prod/rec/processing/idda/OPICS10390_BAL_KOR_20220407101255_20224545565677.txt
/tenants/ct/108251/prod/rec/processing/sap_fv/s4_idn_sap_abcd_tcs_future_20221015_20224545888886.csv
/tenants/ct/108251/prod/rec/processing/sap_fxrates/frontier_sgp_xrates_d_sap_20221105_20221234567812.dat`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}