re = /(.*)\n(\d*)/m
str = 'Banana
67'
subst = 'My name is $1 and I am $2 years old.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result