using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(category \b(\w+)\b )((\b\w+\b)+)";
string input = @"category fruits pear orange
category meat beef duck";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}