re = /(category \b(\w+)\b )((\b\w+\b)+)/i
str = 'category fruits pear orange
category meat beef duck'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end