package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\S*\s*){4}$`)
var str = `house, man, love, me, book, car, verbs, substantives`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}