# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<remote_addr>[\w\.]+) - (?P<remote_user>[^ ]*) \[(?P<time_local>.*)\] (?P<ssl_protocol>[\w\.]+) (?P<ssl_ciphers>[\w\._]+) \"(?P<method>[^ ]*) (?P<request>[^ ]*) (?P<protocol>[^ ]*)\" (?P<status>[\d]+) (?P<body_bytes_sent>[\d]+)"
test_str = ("10.10.1.110 - - [22/Oct/2021:15:59:27 +0700] TLSv1.3 TLS_AES_256_GCM_SHA384 \"GET /files/image/Icon%20Kronika%20Juni%202021(1).jpg HTTP/1.0\" 200 65274\n"
"10.10.1.110 - - [22/Oct/2021:15:59:27 +0700] TLSv1.3 TLS_AES_256_GCM_SHA384 \"GET /files/image/Icon%20Kronika%20Juli-Agustus(1).jpg HTTP/1.0\" 200 71093\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.