re = /^(?P<remote_addr>[\w\.]+) - (?P<remote_user>[^ ]*) \[(?P<time_local>.*)\] (?P<ssl_protocol>[\w\.]+) (?P<ssl_ciphers>[\w\._]+) "(?P<method>[^ ]*) (?P<request>[^ ]*) (?P<protocol>[^ ]*)" (?P<status>[\d]+) (?P<body_bytes_sent>[\d]+)/m
str = '10.10.1.110 - - [22/Oct/2021:15:59:27 +0700] TLSv1.3 TLS_AES_256_GCM_SHA384 "GET /files/image/Icon%20Kronika%20Juni%202021(1).jpg HTTP/1.0" 200 65274
10.10.1.110 - - [22/Oct/2021:15:59:27 +0700] TLSv1.3 TLS_AES_256_GCM_SHA384 "GET /files/image/Icon%20Kronika%20Juli-Agustus(1).jpg HTTP/1.0" 200 71093
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end