// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?P<remote_addr>[\w\.]+) - (?P<remote_user>[^ ]*) \[(?P<time_local>.*)\] (?P<ssl_protocol>[\w\.]+) (?P<ssl_ciphers>[\w\._]+) "(?P<method>[^ ]*) (?P<request>[^ ]*) (?P<protocol>[^ ]*)" (?P<status>[\d]+) (?P<body_bytes_sent>[\d]+)"#).unwrap();
let string = "10.10.1.110 - - [22/Oct/2021:15:59:27 +0700] TLSv1.3 TLS_AES_256_GCM_SHA384 \"GET /files/image/Icon%20Kronika%20Juni%202021(1).jpg HTTP/1.0\" 200 65274
10.10.1.110 - - [22/Oct/2021:15:59:27 +0700] TLSv1.3 TLS_AES_256_GCM_SHA384 \"GET /files/image/Icon%20Kronika%20Juli-Agustus(1).jpg HTTP/1.0\" 200 71093
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}