#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?(DEFINE)" & @CRLF & _
" (?# Date )" & @CRLF & _
" (?# Day ranges )" & @CRLF & _
" (?<d_day28>0[1-9]|1\d|2[0-8])" & @CRLF & _
" (?<d_day29>0[1-9]|1\d|2\d)" & @CRLF & _
" (?<d_day30>0[1-9]|1\d|2\d|30)" & @CRLF & _
" (?<d_day31>0[1-9]|1\d|2\d|3[01])" & @CRLF & _
" (?# Month specifications )" & @CRLF & _
" (?<d_month28>02)" & @CRLF & _
" (?<d_month29>02)" & @CRLF & _
" (?<d_month30>0[469]|11)" & @CRLF & _
" (?<d_month31>0[13578]|1[02])" & @CRLF & _
" (?# Year specifications )" & @CRLF & _
" (?<d_year>\d+)" & @CRLF & _
" (?<d_yearLeap>(?:\d*?(?:(?:0[48]|[13579][26]|[2468][048])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\D|\b))" & @CRLF & _
" (?# Valid date formats )" & @CRLF & _
" (?<d_format>" & @CRLF & _
" (?&d_day28)\/(?&d_month28)\/(?&d_year)|" & @CRLF & _
" (?&d_day29)\/(?&d_month29)\/(?&d_yearLeap)|" & @CRLF & _
" (?&d_day30)\/(?&d_month30)\/(?&d_year)|" & @CRLF & _
" (?&d_day31)\/(?&d_month31)\/(?&d_year)" & @CRLF & _
" )" & @CRLF & _
" " & @CRLF & _
" (?# Time )" & @CRLF & _
" (?# Time properties )" & @CRLF & _
" (?<t_period12>(?i)[ap]m|[ap]\.m\.(?-i))" & @CRLF & _
" (?# Hours )" & @CRLF & _
" (?<t_hours12>0\d|1[01])" & @CRLF & _
" (?<t_hours24>[01]\d|2[0-3])" & @CRLF & _
" (?# Minutes )" & @CRLF & _
" (?<t_minutes>[0-5]\d)" & @CRLF & _
" (?# Seconds )" & @CRLF & _
" (?<t_seconds>[0-5]\d)" & @CRLF & _
" (?# Milliseconds )" & @CRLF & _
" (?<t_milliseconds>\d{3})" & @CRLF & _
" (?# Valid time formats )" & @CRLF & _
" (?<t_format>" & @CRLF & _
" (?&t_hours12):(?&t_minutes):(?&t_seconds)(?:\.(?&t_milliseconds))?\ ?(?&t_period12)|" & @CRLF & _
" (?&t_hours24):(?&t_minutes):(?&t_seconds)(?:\.(?&t_milliseconds))?" & @CRLF & _
" )" & @CRLF & _
" " & @CRLF & _
" (?# Datetime )" & @CRLF & _
" (?<dt_format>(?&d_format)\ (?&t_format))" & @CRLF & _
")" & @CRLF & _
"\b(?&dt_format)\b"
Local $sString = "29/02/2016 23:10:59 - valid" & @CRLF & _
"29/02/2017 23:10:59 - invalid (not leap year)" & @CRLF & _
"30/03/2016 23:10:59 - valid"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")