# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^|\r?\n)(.*?)(?: |\r?\n)([^\s]+?@.*?)(?=\r?\n|$)"
test_str = ("Vicente Clark vicente.clark@gmail.com\n"
"Mark van der Zant\n"
"mark.zant@protonmail.com\n"
"Georgy Collins\n"
"georgy.collins@yahoo.com\n"
"Paul Danilsson\n"
"paul.danilsson@live.com")
subst = "$1: $2\\n\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.