use strict;
my $str = '1870818340915';
my $regex = qr/^[1-9]\d{2}(0[1-9]|1[0-2])(0[1-9]|[12]\d|3[01])(0[1-9]|[1-4]\d|5[0-2]|99)(00[1-9]|0[1-9]\d|[1-9]\d\d)\d$/p;
my $subst = 'CNPJ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";