use strict;
my $str = ' 1er mars 2020
{{1er}} mars 2020
1{{er}} mars 2020
1 mars 2020
20 mars 2020
I don\'t want these ones:
date= 20 Mars 2025
date=20 Mars 2025
{{date|20 aout 2020}}
{{date| 20 aout 2020}}
{{date|20 aout 2020}} 1{{er}} mars 2020 {{date|20 aout 2020}} 1{{er}} mars 2020 1{{er}} mars 2020 1 mars 2020 20 mars 2020 date=20 Mars 2025
12 octobre 2012
foo=12 octobre 2012
foo = 12 octobre 2012
bar|12 octobre 2012
bar | 12 octobre 2012';
my $regex = qr/(?<!(?:\w+ *[=|] *|{{\w+ *\| *)[\w ]*)(?:(\d+(?:er)?|\d+{{er}}|{{\d+er}}) *)?(janvier|f[ée]vrier|mars|avril|mai|juin|juillet|a[ôo][ûu]t|septembre|octobre|novembre|d[ée]cembre) *(\d{3,4})/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}