^start of line
\s*any whitespace character, repeated any number of times
DOthe literal text DO (case sensitive) \s*any whitespace character, repeated any number of times
*matches any number of characters from the set below:
0-9one character from 0 (4810) to 9 (5710)
\s*any whitespace character, repeated any number of times
A-Zone character from A (6510) to Z (9010) (case sensitive)
\s*any whitespace character, repeated any number of times
=the literal = (6110 / 758 / 3D16)
\s*any whitespace character, repeated any number of times
\s*any whitespace character, repeated any number of times
+matches at least one character from the set below:
0-9one character from 0 (4810) to 9 (5710)
+matches at least one character from the set below:
A-Zone character from A (6510) to Z (9010) (case sensitive)
\s*any whitespace character, repeated any number of times
{*the literal { (12310 / 1738 / 7B16) , repeated any number of times
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string