# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"([^"]*)"/“$1”/gm;t' <<< "\"Il cane è giallo\" e mentre gli davo da mangiare \"mi ha morso\"."