re = /^([^:]+::\s*){2}(?<short_message>.*)::/m
str = 'Alert :: Critical :: NXUSWSDD01 :: DATA-DOMAIN-MIB:spaceOver90Percent : sysUpTime = 33 days 22 hours 7 minutes 10.56 seconds, systemSerialNumber = APM00202524576, fileSystemSpaceUsed.2 = 26637.6, alertInfoDescription.48 = Space usage in Data Collection has exceeded 90% threshold. EVT-OBJ::FilesysType=2 EVT-INFO::SpaceUsage(%)=90 :: Storage Traps
Alert::Serious::Server::Memory Utilization is 92 %, which is above threshold 90% & less than 95%::memory.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end