#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-G]{1}([5])?([#b]{1})?(mM|Mm|m|M|aug|dim|add)?([679]|11)?((sus)([24]))?"
Local $sString = "Am7" & @CRLF & _
"" & @CRLF & _
"G9 Sm Dbm6" & @CRLF & _
"Eb7sus2 Bbm9" & @CRLF & _
"" & @CRLF & _
"G7 Aaug Cdim6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")