package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-G]{1}([5])?([#b]{1})?(mM|Mm|m|M|aug|dim|add)?([679]|11)?((sus)([24]))?`)
var str = `Am7
G9 Sm Dbm6
Eb7sus2 Bbm9
G7 Aaug Cdim6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}