use strict;
my $str = 'Am7
G9 Sm Dbm6
Eb7sus2 Bbm9
G7 Aaug Cdim6';
my $regex = qr/[A-G]{1}([5])?([#b]{1})?(mM|Mm|m|M|aug|dim|add)?([679]|11)?((sus)([24]))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}