$re = '/[A-G]{1}([5])?([#b]{1})?(mM|Mm|m|M|aug|dim|add)?([679]|11)?((sus)([24]))?/m';
$str = 'Am7
G9 Sm Dbm6
Eb7sus2 Bbm9
G7 Aaug Cdim6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);