#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([+-]?\d+.)?|.(\d+)?[Ee]?[+-]?\d+[fFlF]?"
Local $sString = "15.75" & @CRLF & _
"1.575E1" & @CRLF & _
"1575e-2" & @CRLF & _
"-2.5e-3" & @CRLF & _
"25E-4" & @CRLF & _
"10.0" & @CRLF & _
"10.0F" & @CRLF & _
".0075e2" & @CRLF & _
"0.075e1" & @CRLF & _
".075e1" & @CRLF & _
"75e-2" & @CRLF & _
"15.75f"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")