const regex = /([+-]?\d+.)?|.(\d+)?[Ee]?[+-]?\d+[fFlF]?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([+-]?\\d+.)?|.(\\d+)?[Ee]?[+-]?\\d+[fFlF]?', 'gm')
const str = `15.75
1.575E1
1575e-2
-2.5e-3
25E-4
10.0
10.0F
.0075e2
0.075e1
.075e1
75e-2
15.75f`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}