// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([+-]?\d+.)?|.(\d+)?[Ee]?[+-]?\d+[fFlF]?").unwrap();
let string = "15.75
1.575E1
1575e-2
-2.5e-3
25E-4
10.0
10.0F
.0075e2
0.075e1
.075e1
75e-2
15.75f";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}