re = /^([a-zA-Z0-9-_]{0,63}\.?[a-zA-Z0-9-_]{1,63}\.[a-zA-Z0-9-_]{1,63}):?(\d{1,5})?$/mi
str = '.com
a.com
aa.com
a.a.com
a.a.a.com
Domain-123.com
subDomain.Domain-123.com
test.subDomain.Domain-123.com
Domain-123.com:12345
subDomain.Domain-123.com:12345
test.subDomain.Domain-123.com:12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end