$re = '/(.*) (.*)$/m';
$str = 'пр. Тараса Шевченка 2/28
ул. 8 Марта 47
пер. Г. Сагайдачного 25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);