// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"event-title">([\w ]+)"#).unwrap();
let string = "<some_tag name=\"event-title\">Some text 1</some-tag>
<some_tag name=\"event-title\">Some text 2</some-tag>
<some_tag name=\"event-title\">Some text 3</some-tag>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}